[SOLUCIONADO] Problemas con wifi y modo avión en Debian 8

Las partes físicas de tu maquina funcionando bajo linux (Tarjeta de video, de sonido, modem, tarjeta de red, monitor, etc.)

Moderador: doc

Responder
RedTX
Forista Nuevo
Forista Nuevo
Mensajes: 5
Registrado: Sab Dic 13, 2014 6:11 pm

[SOLUCIONADO] Problemas con wifi y modo avión en Debian 8

Mensaje por RedTX » Dom Jul 19, 2015 2:40 pm

Muy buenas a tod@s,


He buscado por el foro, entre mensajes anteriores, y no consigo dar con la solución a mi problema. Os lo expongo:

En un Compaq Presario CQ57 que venía con Windows de serie he instalado (eliminando win) varias distros, entre ellas Ubuntu 14.10 y Elementary OS. Con ninguna logré que el wifi funcionara. Hace unos días he instalado Debian 8.1 (eliminando las otras distros) y, tras instalar los drivers de la tarjeta (una Ralink RT5390) y modificar alguna cosilla, logré que funcionara.

Sin embargo, ayer al arrancar (no sé si debido a ello...) presioné la tecla que desactiva el wifi y desde entonces no hay modo de volverlo a activar. Tengo el modo avión activado y no hay manera de desactivarlo, ni por terminal, ni por medios físicos (tecla wireless) ni a través de los parámetros del sistema. Os pongo a continuación las acciones que he realizado:

- Desinstalar el firmware de Ralink y reiniciar el equipo
- Volver a modificar el archivo /etc/apt/sources.list añadiendo la línea
# Debian 8 "Jessie"
deb http://http.debian.net/debian/ jessie main contrib non-free
- en terminal: #update
- Reinstalar el firmware desde synaptics

+ No funciona: el modo avión sigue bloqueado

- en terminal:
#rfkill unblock all
#ifconfig wlan0 up

+ el modo avión sigue activado. Sale el mensaje «la operación no es posible debido a RFKill».

Copio a continuación alguna información de más:

#rfkill list all
0: hp-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

#ifconfig
eth0 Link encap:Ethernet HWaddr e4:11:5b:ff:7d:b6
inet addr:192.168.1.38 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::e611:5bff:feff:7db6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9692 errors:0 dropped:0 overruns:0 frame:0
TX packets:8051 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6166363 (5.8 MiB) TX bytes:1342520 (1.2 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:489 errors:0 dropped:0 overruns:0 frame:0
TX packets:489 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:334167 (326.3 KiB) TX bytes:334167 (326.3 KiB)

#iwconfig
eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

lo no wireless extensions.


¿Alguien puede echarme una mano? Desde ya, muchísimas gracias

[EDITO: el entorno es Gnome]

Editado -- Dom Jul 19, 2015 2:40 pm --

Por si le sirve a alguien:

El problema era que se habían desconfigurado las claves multimedia. Lo arreglé añadiendo lo siguiente a las líneas de comando del GRUB (Esc al reiniciar y en la opción sistema Debian pulsar "e"--> Se abren los comandos del GRUB). Justo a continuación del comando boot con Linux:

modprobe.blacklist=wmi , hp_wmi

Tras ello, arranqué sesión y edité /etc/modprobe.d/blacklist-hp.conf desde terminal, añadiendo la línea

blacklist hp-wifi

De nuevo, en terminal (como root):

# ifconfig wlan0 up

¡Y listo!
Avatar de Usuario
mcun
Administrador
Administrador
Mensajes: 3888
Registrado: Lun Abr 19, 2010 12:30 am
Ubicación: En una de las nalgas del culo del mundo (según la Bersuit Vergarabat)
Contactar:

Re: [SOLUCIONADO] Problemas con wifi y modo avión en Debian 8

Mensaje por mcun » Mar Jul 21, 2015 9:55 pm

gracias por etiqueta el tema camarada
Los programadores de verdad no documentan. La documentación es para los idiotas que no pueden leer un volcado de memoria.

Trusted Network and Developer | Lee el Reglamento !! |WIKI-EL | Twitter @mr_mcun
Debian + TTY | ArchLinux + awesome | openSUSE + Gnome-Shell | Linux User #508809
mmv129
Forista Nuevo
Forista Nuevo
Mensajes: 1
Registrado: Sab Dic 12, 2015 1:58 am

Re: [SOLUCIONADO] Problemas con wifi y modo avión en Debian 8

Mensaje por mmv129 » Sab Dic 12, 2015 2:03 am

Amigo ayudame cuales fueron los pasos ? Me urge activar WiFi paso por paso porfa
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje