Problema con targeta grafica[solucionado]

Las partes físicas de tu maquina funcionando bajo linux (Tarjeta de video, de sonido, modem, tarjeta de red, monitor, etc.)

Moderador: doc

foncu
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Feb 11, 2010 7:53 pm

Problema con targeta grafica[solucionado]

Mensaje por foncu » Jue Feb 11, 2010 9:56 pm

Bueno pues el punto esta en que cuando instale linux karmic koala, y no me reconoce la targeta grafica, o por lo menos no me funciona la aceleracion grafica, tengo una ati radeon shaphire 3650 hd.

Saludos
Última edición por foncu el Lun Feb 15, 2010 10:45 pm, editado 2 veces en total.
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3125
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: Problema con targeta grafica

Mensaje por Yoyo » Jue Feb 11, 2010 11:12 pm

Hola foncu.

No he tenido ati nunca en Linux pero puedes mirar a ver si te sale algun controlador para instalar en Sistema/Administración/Controladores de hardware

Si hay alguno ubuntu te dará la opción a instalarlo, sobre ati no se nada mas.

Tambien puedes usar el buscador del foro con el tema ati + ubuntu y seguro te arroja muchos resultados.



Un saludo.
Avatar de Usuario
hmg79
Forista Legendario
Forista Legendario
Mensajes: 2211
Registrado: Lun Mar 31, 2008 8:00 am

Re: Problema con targeta grafica

Mensaje por hmg79 » Jue Feb 11, 2010 11:33 pm

Sinceramente nunca utilice los drivers libres de ati, que supongo es lo que instala ubuntu, por lo tanto yo te recomiendo lo siguiente:

1.-Bajar de http://support.amd.com/us/gpudownload/Pages/index.aspx, el drivers correspondiente a tu placa de video.-
2.-Verificar que tengas las sources del kernel en /usr/src/, que corresponde a linux-headers-xxxx.xxxx.xxx,
3.-Darle los permisos de ejecución al archivo que bajaste en el primer paso, y ejecutarlo de la siguiente manera:

Código: Seleccionar todo

sh ati-xxxx.xxx.xx.run
Lo tenes que hacer como usuario root, o anteponiendo sudo al sh.-
4.-si en el paso anterior sale todo bien, te va a aparecer un mensaje indicandote que ejecutes aticonfig o algo asi, lo ejecutas con los parametros que creas necesarios, por ejemplo esto es lo que yo suelo utilizar:

Código: Seleccionar todo

aticonfig --initial=dual-head --screen-layout=adove --resolution=0,1440x900,1280x1024,800x600
básicamente le indico que configure para trabajar con dos monitores, y que la resolución por defecto sea de 1440x900, ya que en mi caso siempre se niega a trabajar en esa resolución.-
5.-Reiniciar la sesión gráfica, ctrl+alt+backspace, o "service gdm restart", o reiniciar directamente el equipo
6.-Instalar Mesa y MEsa-utils
7.-verificar ya tenes aceleración gráfica, estos comandos los tenes que ejecutar como usuario:

Código: Seleccionar todo

glxinfo | grep direct
Si el resultado de eso es YES, te indica que ya tenes aceleración gráfica.-
Comandos adicionales que podes utilizar son glxdemo glxgears glxheads.-
Si no funciona habría que ver que esta pasando.-
foncu
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Feb 11, 2010 7:53 pm

Re: Problema con targeta grafica

Mensaje por foncu » Vie Feb 12, 2010 9:49 am

Gracias por las ayuda probare y notificare los resultados
Avatar de Usuario
hmg79
Forista Legendario
Forista Legendario
Mensajes: 2211
Registrado: Lun Mar 31, 2008 8:00 am

Re: Problema con targeta grafica

Mensaje por hmg79 » Vie Feb 12, 2010 4:22 pm

No se que versión de xorg y xserver, tendrá esa versión de Ubuntu, pero si tiene la versión 7.5, no se pueden instalar los drivers oficiales bajados de la pagina de ATI, solamente funciona con versiones inferiores del xorg, hasta la 7.4 o 7.3, los vagos de ATI se estan quedando relegados, parece que recién la versión 10.4, va a tener soporte para Xorg 7.5, o sea dentro de 4meses.-

Para los que utilizamos Debian Squeeze, si no se encontraron todavía con este problema por lo menos la solución que encontre fue mediante apt-pinning instalar con aptitude el xorg de lenny.-
foncu
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Feb 11, 2010 7:53 pm

Re: Problema con targeta grafica

Mensaje por foncu » Vie Feb 12, 2010 5:11 pm

hmg79 escribió:Sinceramente nunca utilice los drivers libres de ati, que supongo es lo que instala ubuntu, por lo tanto yo te recomiendo lo siguiente:

1.-Bajar de http://support.amd.com/us/gpudownload/Pages/index.aspx, el drivers correspondiente a tu placa de video.-
2.-Verificar que tengas las sources del kernel en /usr/src/, que corresponde a linux-headers-xxxx.xxxx.xxx,
3.-Darle los permisos de ejecución al archivo que bajaste en el primer paso, y ejecutarlo de la siguiente manera:

Código: Seleccionar todo

sh ati-xxxx.xxx.xx.run
Lo tenes que hacer como usuario root, o anteponiendo sudo al sh.-
Lo primero pedir perdon por ser tan terco pero soy un tanto nuevo. Me quedo aqui, Descargo el archivo necesario para mi tarjeta, verifico las sources del kernel son "linux-headers-2.6.31-16-linux-headers-2.6.31-16 generic y linux-headers-2.6.31-19 y linux-headers-2.6.31-19 generic" al archivo que me descarge le di los permisos de ejecucion mediante chmod, pero a la hora de ejecutarlo, me salta un error no se si es devido a que situo mal el comando o el promt. Podria preguntar a ser posible una muestra de como quedaria el resultado del comando sh.

Gracias
Avatar de Usuario
hmg79
Forista Legendario
Forista Legendario
Mensajes: 2211
Registrado: Lun Mar 31, 2008 8:00 am

Re: Problema con targeta grafica

Mensaje por hmg79 » Vie Feb 12, 2010 6:35 pm

Te tenes que situar en donde bajaste tu archivo, por ejemplo yo las cosas que voy bajando de internet, las tengo en una carpeta llamada descargas, que se encuentra en mi home, por lo tanto lo que hago para asegurarme que estoy en el lugar correcto es simplemente:

Código: Seleccionar todo

$cd /home/usuario/descargas
esto me lleva al directorio de descargas
Una ves ahi verifico el nombre del archivo de ati, ya que tengo varios, para eso hago:

Código: Seleccionar todo

$ls 
esto lo que hace es listarme el contenido del directorio en cuestión

Y por ultimo ejecuto el comando, por ejemplo en mi caso el drivers se llama ati-driver-installer-10-1-x86.x86_64.run, por lo tanto ejecuto:

Código: Seleccionar todo

$sudo sh ati-driver-installer-10-1-x86.x86_64.run
Esto te va a lanzar el instalador de ati.-

Si todo sale bien te dice que ejecute aticonfig --initial.-
foncu
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Feb 11, 2010 7:53 pm

Re: Problema con targeta grafica

Mensaje por foncu » Vie Feb 12, 2010 7:10 pm

Vale ya he logrado abrir el lanzador de la instalacion de ati y se a completado correctamente, el sigiente problema esta aqui, he intentado ejecutar el siguiente comando que colocaste en el primer post:

Código: Seleccionar todo

aticonfig --initial=dual-head --screen-layout=adove --resolution=0,1440x900,1280x1024,800x600
Y me da el siguiente mensaje:

Código: Seleccionar todo

Found fglrx primary device section
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-0
Mi duda ahora surge en si tengo que editar algo del archivo /etc/X11/xorg.conf o si tengo que ejecutarlo o algo por el estilo.

Gracias otra vez
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Problema con targeta grafica

Mensaje por niky45 » Vie Feb 12, 2010 10:29 pm

no, se supone que ya esta.... ahora simplemente, reinicias las X : /etc/init.d/gdm restart #(como root o con sudo), y deberia estar....

:)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
hmg79
Forista Legendario
Forista Legendario
Mensajes: 2211
Registrado: Lun Mar 31, 2008 8:00 am

Re: Problema con targeta grafica

Mensaje por hmg79 » Vie Feb 12, 2010 11:31 pm

foncu escribió:Vale ya he logrado abrir el lanzador de la instalacion de ati y se a completado correctamente, el sigiente problema esta aqui, he intentado ejecutar el siguiente comando que colocaste en el primer post:

Código: Seleccionar todo

aticonfig --initial=dual-head --screen-layout=adove --resolution=0,1440x900,1280x1024,800x600
Y me da el siguiente mensaje:

Código: Seleccionar todo

Found fglrx primary device section
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-0
Mi duda ahora surge en si tengo que editar algo del archivo /etc/X11/xorg.conf o si tengo que ejecutarlo o algo por el estilo.

Gracias otra vez

Como dice niky45, con eso ya esta, ese mensaje indica que se configuro correctamente el xorg, y que ya podes reiniciar las X o reiniciar el ordenador.-
foncu
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Feb 11, 2010 7:53 pm

Re: Problema con targeta grafica

Mensaje por foncu » Vie Feb 12, 2010 11:59 pm

Ciertamente ya se actualizo, gracias, ahora me surge otra duda:

En linux he podido comprobar que en las preferencias de apariencia hay una partado que pone efectos visuales, lo tengo situado en ninguno, y me gustaria activarlo pero me dice que no se encuentran controladores.

Alguna solucion ??

Saludos y gracias ^^
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Problema con targeta grafica

Mensaje por niky45 » Lun Feb 15, 2010 12:16 am

instala el mesa-utils, y verifica que este tirando del driver de ati:

glxgears te tiene que tirar muchas fps
glxinfo | grep direct te tiene que decir que si
glxinfo| grep esa CREO que no te tiene que decir nada (ahora mismo estoy en otra maquina, con nvidia)

si pasa el test, el driver esta funcionando, y lo que pasa es que el sistema esta tonto. :| si no.... tema del driver.

:)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
hmg79
Forista Legendario
Forista Legendario
Mensajes: 2211
Registrado: Lun Mar 31, 2008 8:00 am

Re: Problema con targeta grafica

Mensaje por hmg79 » Lun Feb 15, 2010 1:54 am

Como dice niky hay que instalar el mesa-utils, no se que pasa pero ahora hay que reiniciar el equipo para que se active correctamente los drivers de ati, si se inicia solamente las X, no detecta la aceleración gráfica.-
foncu
Forista Nuevo
Forista Nuevo
Mensajes: 14
Registrado: Jue Feb 11, 2010 7:53 pm

Re: Problema con targeta grafica

Mensaje por foncu » Lun Feb 15, 2010 5:21 pm

Bueno ya esta solucionado todo, efectivamente he logrado activar los efectos visuales instalando el mesa-utils.
Gracias a todos por la ayuda ofrecida ^^ y espero k este tema le sirva a mas gente que le pase los mimo **
Avatar de Usuario
Deckon
Moderador
Moderador
Mensajes: 3273
Registrado: Dom Abr 01, 2007 8:00 am
Ubicación: México, Estado de México

Re: Problema con targeta grafica

Mensaje por Deckon » Lun Feb 15, 2010 6:34 pm

Por favor foncu si consideras que tu duda a sido resuelta coloca la etiqueta [solucionado] en el titulo de tu post.
Reglamento del Foro | Temas mas Preguntados | WikiEL | GitHub
Linux User #:406092
Manjaro | Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610 | Hp Ultrabook Folio 13
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje