Problema con drivers nVidia

Las partes físicas de tu maquina funcionando bajo linux (Tarjeta de video, de sonido, modem, tarjeta de red, monitor, etc.)

Moderador: doc

Responder
Avatar de Usuario
blakeyed
Forista Nuevo
Forista Nuevo
Mensajes: 33
Registrado: Dom Feb 13, 2011 9:51 pm

Problema con drivers nVidia

Mensaje por blakeyed » Dom Feb 13, 2011 10:17 pm

Hola a todos, tengo en mis manos (no es mio, por suerte o por desgracia) un portátil Toshiba Satellite A660 1EM, con dos GPUs, una Intel y otra nVidia. El tema es que la nVidia no consigo echarla a andar en Linux, estoy probando con Linux Mint 10, he visto que la gráfica está soportada, y tengo los drivers recién bajados de la web, pero al iniciar Xorg, me dice que no cards found.

Con los drivers de Intel funciona perfectamente, pero el equipo se calienta mucho, espero que con los de nVidia no tanto. No sé qué probar, al instalar los drivers con synaptic y cargar el módulo me decía "hardware not found", pero la tarjeta está y funciona.

No sé qué hacer

Alguna idea?

Thanks
Saludos
Gaspar Fernández
http://totaki.com/poesiabinaria
Avatar de Usuario
neurus
Forista Legendario
Forista Legendario
Mensajes: 1801
Registrado: Dom Oct 10, 2004 7:00 am

Re: Problema con drivers nVidia

Mensaje por neurus » Dom Feb 13, 2011 10:58 pm

Sigue esta guía.

Luego, si falla, sé lo más explícito posible al comentar qué falla.
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Problema con drivers nVidia

Mensaje por niky45 » Lun Feb 14, 2011 12:53 am

con dos GPUs, una Intel y otra nVidia.
si quieres que trabaje con una o con otra, lo primero es especificarlo desde la bios (desconozco si lo has hecho ya, porque no nos lo has dicho, pero por si acaso....).

una vez que esta desde la bios... bueno, la guia que te pasa neurus es buena. (busca mi respuesta por ahi... es mas sencilla. :P )

EDIT:
Con los drivers de Intel funciona perfectamente, pero el equipo se calienta mucho, espero que con los de nVidia no tanto.
tengo serias dudas. la intel sera "integrada" y la nvidia "pci" (si es que hacen algo asi en los portatiles). aka, la nvidia sera mas potente, y probablemente consuma mas. aunque tambien es probable qu epor eso mismo lleve una mejor refrigeracion. si tan solo nos dijeses el chip que lleva cada una... (si no tienes ni idea, lspci te dara este dato. )
:)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
blakeyed
Forista Nuevo
Forista Nuevo
Mensajes: 33
Registrado: Dom Feb 13, 2011 9:51 pm

Re: Problema con drivers nVidia

Mensaje por blakeyed » Lun Feb 14, 2011 8:03 pm

A ver, he seguido el tutorial, he eliminado los drivers de nouveau (que se resistían), pero no funciona. He conseguido cargar el módulo de nvidia.

Pero cuando hago startx,

(EE) No devices detected.

Fatal server error:
no screens found

lo único que tengo en xorg.conf es lo siguiente:
Section "Device"
Identifier "Default Device"
Driver "nvidia"
EndSection

Si coloco en lugar de nvidia "intel" funciona perfectamente, pero es que no quiero que se active la Intel.

Por lo de la optimización, la nVidia pondrá más electrónica en funcionamiento, pero los drivers de este están mejor que los de Intel, bueno, aunque el rerigerador y la ventilación buena estén en la nVidia.

La CPU es una i5 y estas Intel tienen una GPU Intel 965 integrada, lo que pasa es que el portátil tiene una nvidia también, PCI, sí, modelo 330M.

Sabéis cómo puedo echarlo a andar?

Gracias
Saludos
Gaspar Fernández
http://totaki.com/poesiabinaria
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3126
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: Problema con drivers nVidia

Mensaje por Yoyo » Lun Feb 14, 2011 8:07 pm

Mi hermano tiene un Mac Book Pro y tambien usa ambas graficas, una Nvidia y una Intel. Normalmente solo hace uso de una, creo que de la Nvidia y en caso de sobre-trabajo acude a la Intel. Eso lo gestiona Snow Leopard solo.

Entonces, donde yo quiero llegar, no se en Linux como irá eso y llego a donde decía niky45.

¿Tienes las dos gráficas a la vez? ¿No puedes anular una, la intel, desde la bios y quedarte solo con la nvidia, por ejemplo?
Avatar de Usuario
blakeyed
Forista Nuevo
Forista Nuevo
Mensajes: 33
Registrado: Dom Feb 13, 2011 9:51 pm

Re: Problema con drivers nVidia

Mensaje por blakeyed » Mar Feb 15, 2011 10:02 pm

Eso es, en Bios no hay ninguna opción. Y debería haber una opción para cambiar entre una y otra, pero no la veo.

Investigando veo el archivo /sys/kernel/debug/vga_switcheroo/ tengo switcheroo instalado, y el modeset a 1, pero no veo el directorio ni sus archivos para desactivar alguna GPU.

Editado -- Mar Feb 15, 2011 9:02 pm --

He estado investigando, y el portátil que tengo utiliza la tecnología Optimus, nVidia no planea hacer drivers para ello, ya que el modelo utilizado es exclusivo para Windows7 y ellos no van a portar el driver.

La gente de nouveau lo está intentando, pero aún no funciona, me quedo con el portátil sin nvidia, o lo devolveré a la tienda, que tiene sólo 4 días...

Saludos
Saludos
Gaspar Fernández
http://totaki.com/poesiabinaria
Avatar de Usuario
Yoyo
Administrador
Administrador
Mensajes: 3126
Registrado: Mar Jun 06, 2006 7:00 am
Ubicación: España
Contactar:

Re: Problema con drivers nVidia

Mensaje por Yoyo » Mar Feb 15, 2011 10:06 pm

Pues es una pena que lo devuelvas en caso de que sea buen portatil.

Los que somos de Linux, antes de comprar un portatil, es aconsejable informarse del hardaware que lleva antes de comparlo, yo en estos casos siempre recomiendo que lleve procesadores Intel, gráficas Nvidia y wifi atheros o intel que funcionan bien en Linux.

Lo de la tecnología Optimus nunca lo había escuchado 0.O

Saludos.
Avatar de Usuario
niky45
Forista Ancestral
Forista Ancestral
Mensajes: 9186
Registrado: Jue Abr 12, 2007 7:00 am
Ubicación: tras la pantalla (...)
Contactar:

Re: Problema con drivers nVidia

Mensaje por niky45 » Mar Feb 15, 2011 10:37 pm

Yoyo escribió:Pues es una pena que lo devuelvas en caso de que sea buen portatil.

Los que somos de Linux, antes de comprar un portatil, es aconsejable informarse del hardaware que lleva antes de comparlo, yo en estos casos siempre recomiendo que lleve procesadores Intel, gráficas Nvidia y wifi atheros o intel que funcionan bien en Linux.

Lo de la tecnología Optimus nunca lo había escuchado 0.O

Saludos.
yo sobre todo me conformo con que la wifi no sea broadcom. el resto..... si de un portatil se trata, poco hay donde elegir :cry: si es un sobremesa, por piezas, por supuesto :D

y por cierto, offtopic: parece ser que esta vez lo de grafica nvidia no ha funcionado :P

yo creo, que si se puede deolver, es la mejor opcion. te da igual que sea bueno, si no tienes soporte. y.. digo yo que algun otro habra parecido que SI que te de soporte. :)
#446716
>>"Linux: the operating system with a CLUE... Command Line User Environment".
(seen in a posting in comp.software.testing)

[ DNFD ] - [ F4A ] - [ dotfiles ]
Avatar de Usuario
doc
Forista Ancestral
Forista Ancestral
Mensajes: 3257
Registrado: Mié Ago 11, 2010 10:32 am
Ubicación: Oviedo-es_ES
Contactar:

Re: Problema con drivers nVidia

Mensaje por doc » Mar Feb 15, 2011 10:56 pm

si ya has instalado los drivers de nVidia... ¿has desinstalado y además puesto en la blacklist de modprobe el nouveau? En mis "apuntes tácticos" yo tengo puesto esto:
Ahora, a pesar de haberlo desinstalado, nouveau sigue 'mandando algo' así que vamos a agregarlo a la blacklist en el /etc/modprobe.d/blacklist.conf pues a mí me seguía dando conflictos y no me dejaba instalar los Nvidia.
Para eso hago
# gedit /etc/modprobe.d/blacklist.conf
Y al final del archivo que se nos abre añadimos...
# no nouveau
blacklist nouveau
Guardamos cambios y cerramos.
A lo mejor tienes algún conflictillo con esta historia (que no me pidas que lo explique, para eso está nicky, yo solo soy un novatillo que apunta cosas que me parecen de interés, para mis propios Howto)
Avatar de Usuario
blakeyed
Forista Nuevo
Forista Nuevo
Mensajes: 33
Registrado: Dom Feb 13, 2011 9:51 pm

Re: Problema con drivers nVidia

Mensaje por blakeyed » Mié Feb 16, 2011 12:12 pm

Pues sí, es una lástima, y el portátil me encanta. Envié un mensaje al centro de soporte Linux de Toshiba, normal que no me contesten tan rápido, pero aprovechando que lo compré en El Corte Inglés, voy a devolverlo pronto y ya buscaré otro ordenador tranquilamente. Viendo por Internet es el único de la gama Toshiba A660 que tiene Optimus...

Me apresuré en la compra del portátil porque corría prisa, se murió mi anterior portátil y lo necesitaba para un trabajo que al final no he podido hacer porque paso de instalarlo todo en Windows7 (que por cierto me estresa y nada más encenderlo tuve problemas con la Broadcom).

Saludos
Saludos
Gaspar Fernández
http://totaki.com/poesiabinaria
Responder
  • Similar Topics
    Respuestas
    Vistas
    Último mensaje