Reglamento general de los foros   •   FAQ   •   Buscar en el foro •  Registrarse | Iniciar sesión 



Portada » Foros Linux » Filosofía y conocimiento » Documentación


Nuevo tema Responder al tema
 [ 31 mensajes ]  Ir a página Anterior  1, 2, 3  Siguiente
Patrocinadores

Autor
Buscar:
Mensaje

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Dom May 29, 2005 7:00 am
Mensajes: 407
Ubicación: Panamá

Nota Publicado: Vie May 10, 2013 5:19 pm 
Arriba  
jony127 escribió:
yo quiero estar en testing como antes pero he cambiado mis repos a la estable porque he leído que es recomendable hacerlos durante los 2 o 3 primeros meses hasta que la testing se estabilice, por eso estoy en estable, no se hasta que punto esto es cierto porque si no estaría ya en testing pero me preocupa que se me venga abajo el sistema y tenga que perder el tiempo reinstalando que es lo que quiero evitar.

Saludos.


En Debian, puedes subir pero no bajar; es decir, si estás en Testing, puedes subir a Sid pero no bajar a Stable.
Cada uno sabe dónde amarra su caballo, yo, personalmente, volvería a Testing y cruzaría los dedos, porque es probable que se avecine una tormenta de caca :) Haz el clone como dice 'doc' por si las moscas.

Los usuarios que usan Testing o Sid lo hacen porque quieren sistemas con lo último en paquetes, y no les importa arreglar el sistema con la ayuda de foros, el resultado es una curva de aprendizaje; con la desventaja que a veces se rompen porque se están probando dichos paquetes, de ahí el nombre: Testing.

En Sid, (el niño de la historia que rompía los juguetes) y donde se estrenan los paquetes nuevos es inestable, y sólo para masoquistas como yo, que les gusta estar en problemas y les encanta estar loqueando con el sistema, arreglando y aprendiendo.

Para los profesionales, que no tienen tiempo para arreglar cosas, y que lo que necesitan es un distro que no se rompa y puedan usar su ordenador y terminar el trabajo a mano, usan Stable. No están interesados en los últimos paquetes, ni pijadas. Por eso tengo a Sid en un ordenador y Stable en otro, cuando Sid se rompa, cambio de ordenador :)
He ahí donde entran los repositorios de backports con paquetes nuevos exclusivamente para Stable.

Editado -- Vie May 10, 2013 10:19 am --

Para los usuarios de Testing y Sid: es aconsejable que instalen el paquete 'apt-listbugs'

_________________
debian wheezy / minimal install / icewm / vimperator
"Entre más lideo con gente, más quiero a mi perro" - Oscar Wilde
"No good deed will go unpunished" - Anonymous

 Perfil  

Desconectado
Forista Mayor
Forista Mayor
Avatar de Usuario

Registrado: Jue Ago 24, 2006 7:00 am
Mensajes: 598

Nota Publicado: Sab May 11, 2013 7:40 pm 
Arriba  
mmm me has metido el miedo en el cuerpo jeje, na que es broma.

La verdad estaba ya pensando en cambiar los repos de wheezy a jessie para probar en mis propias carnes lo problemático o no del cambio pero me lo voy a tener que pensar un poco más. No me supone ningún problema esperar dos meses para hacer el cambio y estar algo más seguro pero he leído a gente que lleva años con debian y nunca han tenido problemas en testing por eso sigo en la duda si de verdad es relativamente fácil que se me pueda romper el sistema.

Supongo que a los 2 meses el cambio ya sería "seguro" ¿aunque sean solo 2 meses? porque me parece poco. Viendo esto me pregunto como tiene que ser vivir en Arch, ¿una constante aventura? porque parece que las rolling release no ofrecen mucha fiabilidad entre los usuarios :?

 Perfil  

Desconectado
Forista Ancestral
Forista Ancestral
Avatar de Usuario

Registrado: Mié Ago 11, 2010 10:32 am
Mensajes: 3234
Ubicación: Oviedo-es_ES

Nota Publicado: Sab May 11, 2013 8:33 pm 
Arriba  
pues yo acabo de apuntar com mis repos a testing y no pasa nada, solo algún simple arreglito, sin importancia. Claro que yo siempre actualizo en safe-upgrade. Vamos, que me tengo montado este sencillo script
Código:
#!/bin/sh
sudo aptitude update
sudo aptitude safe-upgrade
gedit /var/log/aptitude +8000:1

y me es muy cómodo (me he creado un lanzador desde el escritorio)

 Perfil WWW  

Desconectado
Forista Mayor
Forista Mayor
Avatar de Usuario

Registrado: Jue Ago 24, 2006 7:00 am
Mensajes: 598

Nota Publicado: Dom May 12, 2013 1:09 am 
Arriba  
Al final he dedicido seguir en wheezy al menos hasta que salga la nueva versión de kde para testing y entonces ya veré si doy o no el salto.

Tengo una duda con respecto a los repos de backports y updates que se deben agregar a wheezy y es que en la releases notas dice esto:

Tenga en cuenta que si ha configurado APT::Default-Release en su archivo de configuración /etc/apt/apt.conf (o en cualquier archivo en /etc/apt/apt.conf.d/*), es necesario añadir el siguiente bloque de configuración en /etc/apt/preferences para que las actualizaciones automáticas funcionen (para más información consulte apt_preferences(5)):

Package: *
Pin: release o=Debian,n=wheezy-updates
Pin-Priority: 990


Esta parte no me queda claro, para empezar no he configurado nada de APT::Default-Release porque ni se que significa ni para que sirve eso, pero supongo que por si acaso no hay problema en agregar ese código que inidican. En la primera página de este post ponen que se debe agregar ese código en /etc/apt/apt.conf que en mi caso no dispongo de ese archivo si no del directorio /etc/apt/apt.conf.d y dentro ya varios archivos, pero como pueden ver en la releases notes indican que eso de debe agregar en /etc/apt/preferences que tampoco cuento con ese archivo sino con el directorio /etc/apt/preferences.d y por cierto está vacío.

A ver si alguien que conozca del tema me aclara esto un poco más y donde debo introducir esa información.

Gracias.

 Perfil  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Dom May 29, 2005 7:00 am
Mensajes: 407
Ubicación: Panamá

Nota Publicado: Dom May 12, 2013 5:06 am 
Arriba  
Lo de /etc/apt/preferences significa que si haces un upgrade de una versión anterior (squeeze) a la nueva (wheezy) tienes que hacer esto. Pero si instalas Stable (wheezy) entonces entras esa información como puse en el post original (en apt.conf) de este hilo.

El /etc/apt/apt.conf está en blanco por defecto, pegas la info, salvas y cierras.En el pasado, ignoro esto y sólo pongo en el apt.conf:
APT::Default-Release "wheezy";

_________________
debian wheezy / minimal install / icewm / vimperator
"Entre más lideo con gente, más quiero a mi perro" - Oscar Wilde
"No good deed will go unpunished" - Anonymous

 Perfil  

Desconectado
Forista Mayor
Forista Mayor
Avatar de Usuario

Registrado: Jue Ago 24, 2006 7:00 am
Mensajes: 598

Nota Publicado: Dom May 12, 2013 1:58 pm 
Arriba  
ok perfecto no tenía ni idea de este tema, claro que cuando empecé con debian (no llevo mucho tiempo) fue directamente con testing.

En mi caso ni siquiera existen los archivos /etc/apt/apt.conf ni el /etc/apt/preferences así que tuve que crearlos según tus instrucciones gracias. Ahora ya tendré en cuenta esto para cuando salga la próxima estable.

Cuando pase de nuevo a testing debo eliminar esos dos nuevos repos y el archivo apt.conf no??

Gracias.

Tengo un problema, cuando ejecuto un aptitude update me sale esto:

E: Error de sintaxis /etc/apt/apt.conf:4: Basura extra al final del archivo


Lo he revisado y no veo nada extraño.

 Perfil  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Dom May 29, 2005 7:00 am
Mensajes: 407
Ubicación: Panamá

Nota Publicado: Lun May 13, 2013 4:51 am 
Arriba  
jony127 escribió:
ok perfecto no tenía ni idea de este tema, claro que cuando empecé con debian (no llevo mucho tiempo) fue directamente con testing.


Un error muy común en los novatos que vienen de Windows, quieren correr antes de gatear, Linux no es como Windows, "apuntar y hacer click no es nuestro modus operandi".

Citar:
Cuando pase de nuevo a testing debo eliminar esos dos nuevos repos y el archivo apt.conf no??


Correcto.

Citar:
Tengo un problema, cuando ejecuto un aptitude update me sale esto:

E: Error de sintaxis /etc/apt/apt.conf:4: Basura extra al final del archivo


Lo he revisado y no veo nada extraño.


A mí también. Tengo que preguntar en los foros americanos.
Lo quité y puse esto en su lugar en /etc/apt/apt.conf:
Código:
APT::Default-Release "wheezy";


Desinstalé Sid e instalé Debian 7 (Stable) con un cd fresco.

Editado -- Dom May 12, 2013 9:51 pm --

Citar:
Tengo un problema, cuando ejecuto un aptitude update me sale esto:

E: Error de sintaxis /etc/apt/apt.conf:4: Basura extra al final del archivo

Lo he revisado y no veo nada extraño.


Antes de preguntar en los foros leí de nuevo el Release de Debian 7.0
http://www.debian.org/releases/stable/i ... le-updates Sección 2.2.9
Código:
"Para poder utilizar los paquetes de wheezy-updates puede añadir una entrada en su archivo de configuración sources.list:

deb     http://mirrors.kernel.org/debian wheezy-updates main contrib
deb-src http://mirrors.kernel.org/debian wheezy-updates main contrib

La próxima vez que ejecute apt-get update, el sistema se dará cuenta de los paquetes que haya en la sección wheezy-updates y los considerará cuando busque actualizaciones para los paquetes del sistema."


Lo cual añadí a mis sources.list:
Código:
macondo@foo:~$ cat /etc/apt/sources.list
 
#Debian
deb http://ftp.us.debian.org/debian/ wheezy main non-free contrib
deb-src http://ftp.us.debian.org/debian/ wheezy main non-free contrib

#Security
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free

deb http://mirrors.kernel.org/debian wheezy-updates main contrib
deb-src http://mirrors.kernel.org/debian wheezy-updates main contrib


#Multimedia
deb http://www.deb-multimedia.org wheezy main non-free
# deb http://www.deb-multimedia.org wheezy-backports main
macondo@foo:~$


Luego sigue diciendo:
Código:
"Tenga en cuenta que si ha configurado APT::Default-Release en su archivo de configuración /etc/apt/apt.conf (o en cualquier archivo en /etc/apt/apt.conf.d/*), es necesario añadir el siguiente bloque de configuración en /etc/apt/preferences para que las actualizaciones automáticas funcionen (para más información consulte apt_preferences(5)): "

Package: *
Pin: release o=Debian,n=wheezy-updates
Pin-Priority: 990


Y lo añado en /etc/apt/preferences:

Código:
macondo@foo:~$ cat /etc/apt/preferences
Package: *
Pin: release o=Debian,n=wheezy-updates
Pin-Priority: 990

y luego hago un apt-get update y no dá errores

Saludos,

_________________
debian wheezy / minimal install / icewm / vimperator
"Entre más lideo con gente, más quiero a mi perro" - Oscar Wilde
"No good deed will go unpunished" - Anonymous

 Perfil  

Desconectado
Forista Mayor
Forista Mayor
Avatar de Usuario

Registrado: Jue Ago 24, 2006 7:00 am
Mensajes: 598

Nota Publicado: Lun May 13, 2013 2:32 pm 
Arriba  
macondo escribió:
Lo de /etc/apt/preferences significa que si haces un upgrade de una versión anterior (squeeze) a la nueva (wheezy) tienes que hacer esto. Pero si instalas Stable (wheezy) entonces entras esa información como puse en el post original (en apt.conf) de este hilo.


Entonces esa información que resalto en negrita no es correcta, por eso en mi post anterior te comentaba que en las releases notes decía que el código:

Package: *
Pin: release o=Debian,n=wheezy-updates
Pin-Priority: 990


se debía colocar en /etc/apt/preferences y no en apt.conf como tú me decías, entonces el error es ese.

Un apunte sobre el apt.conf ¿es lo mismo poner como dicen en las releases notes APT::Default-Release que APT::Default-Release "wheezy"?

Y una última consulta sobre los repos:

# wheezy-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free

deb http://mirrors.kernel.org/debian wheezy-updates main contrib
deb-src http://mirrors.kernel.org/debian wheezy-updates main contrib


No son los mismos repositorios salvo que apuntando a servers distintos??

Por cierto no llevo dos días en linux sino varios años pero como digo, en debian si llevo menos tiempo y estas cosas pues las desconocía ya que es la primera cogelación que me pilla.

Saludos.

 Perfil  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Jue Ene 07, 2010 1:06 am
Mensajes: 186
Ubicación: en la orbita de jupiter

Nota Publicado: Lun May 13, 2013 3:19 pm 
Arriba  
jony127 escribió:
mmm me has metido el miedo en el cuerpo jeje, na que es broma.

La verdad estaba ya pensando en cambiar los repos de wheezy a jessie para probar en mis propias carnes lo problemático o no del cambio pero me lo voy a tener que pensar un poco más. No me supone ningún problema esperar dos meses para hacer el cambio y estar algo más seguro pero he leído a gente que lleva años con debian y nunca han tenido problemas en testing por eso sigo en la duda si de verdad es relativamente fácil que se me pueda romper el sistema.

Supongo que a los 2 meses el cambio ya sería "seguro" ¿aunque sean solo 2 meses? porque me parece poco. Viendo esto me pregunto como tiene que ser vivir en Arch, ¿una constante aventura? porque parece que las rolling release no ofrecen mucha fiabilidad entre los usuarios :?


menos miedo, que esto no es Ubuntu :P llevo con mis repos apuntando hacia testing desde que Squeeze pasó a stable y no ha habido problemas de mención. (solo una actualización de xorg que era incompatible con los driver privativos de nvidia. total 15 días funcionando con nouveau hasta que llegó la actualización de nvidia)
desde que Wheezy pasó a stable ha habido un par de actualizaciones importantes (hoy se acaba de actualizar xorg, nvidia...) y todo va como la seda :)
además un poco de emoción viene bien, que stable es muy aburrida :wink:
saludos

_________________
We were but stones, your light made us stars

Debian testing + Openbox --- Arch + Xfce4
http://linuxveredas.blogspot.com/ http://identi.ca/hall9000

 Perfil WWW  

Desconectado
Administrador
Administrador
Avatar de Usuario

Registrado: Mar Jun 06, 2006 7:00 am
Mensajes: 3094
Ubicación: Andalucía/España

Nota Publicado: Lun May 13, 2013 3:44 pm 
Arriba  
Yo lo que no tengo claro son los llamados repositorios updates que comenta el compañero macondo.

Código:
# wheezy-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free


Nunca los he usado ni en anteriores Debian, ni en otros sitios, como por ejemplo en esdebian, veo que hagan mención a ellos http://www.esdebian.org/wiki/introducci ... ios-debian

Este es mi sources.list y va como la seda. (CrunchBang / Wheezy based)

Código:
## CRUNCHBANG
## Compatible with Debian Wheezy, but use at your own risk.
deb http://packages.crunchbang.org/waldorf waldorf main
#deb-src http://packages.crunchbang.org/waldorf waldorf main

## DEBIAN
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free

## DEBIAN SECURITY
deb http://security.debian.org/ wheezy/updates main contrib non-free
#deb-src http://security.debian.org/ wheezy/updates main contrib non-free

## DEBIAN BACKPORTS
deb http://ftp.fr.debian.org/debian/ wheezy-backports main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ wheezy-backports main contrib non-free

## MULTIMEDIA
deb http://www.deb-multimedia.org wheezy main non-free

## DEBIAN EXPERIMENTAL
deb http://ftp.fr.debian.org/debian experimental main

_________________
Reglamento del Foro

Informáticamente hablando...

 Perfil WWW  

Desconectado
Forista Distinguido
Forista Distinguido
Avatar de Usuario

Registrado: Mar May 03, 2011 7:09 am
Mensajes: 1088

Nota Publicado: Lun May 13, 2013 5:23 pm 
Arriba  
macondo escribió:
Lo de /etc/apt/preferences significa que si haces un upgrade de una versión anterior (squeeze) a la nueva (wheezy) tienes que hacer esto. Pero si instalas Stable (wheezy) entonces entras esa información como puse en el post original (en apt.conf) de este hilo.

El /etc/apt/apt.conf está en blanco por defecto, pegas la info, salvas y cierras.En el pasado, ignoro esto y sólo pongo en el apt.conf:
APT::Default-Release "wheezy";

Creo que aquí están mal.
Este método de "preferenses" es cuando tienen un sistema mixto, pero si cambias los repositorios para cambiar a wheezy, no hay necesidad de preferenses, solamente hacer los safe-upgrade, y el full upgrade.
Y no estamos en un sistema mixto. para hacer el aptr/preferenses
http://linux.die.net/man/5/apt_preferences
http://foro.ubuntu-guia.com/Sistemas-Mi ... 93897.html

Editado -- Lun May 13, 2013 9:19 am --

Y con respecto al "pining"
si miramos bien el articulo de debian: http://www.debian.org/releases/wheezy/a ... le-updates
Citar:
2.2.9. La sección «stable-updates»

Algunos paquetes de proposed-updates también pueden ofrecerse a través del mecanismo wheezy-updates. Esta ruta será utilizada para actualizaciones que muchos usuarios pueden querer instalar en su sistema antes de que se realice la siguiente publicación de una versión menor, como puedan ser actualizaciones a motores antivirus y datos de zonas horarias. Todos los paquetes de wheezy-updates se incluirán en la publicación de las versiones menores.

Para poder utilizar los paquetes de wheezy-updates puede añadir una entrada en su archivo de configuración sources.list:

Código:
deb     http://mirrors.kernel.org/debian wheezy-updates main contrib
deb-src http://mirrors.kernel.org/debian wheezy-updates main contrib


La próxima vez que ejecute apt-get update, el sistema se dará cuenta de los paquetes que haya en la sección wheezy-updates y los considerará cuando busque actualizaciones para los paquetes del sistema.

Tenga en cuenta que si ha configurado APT::Default-Release en su archivo de configuración /etc/apt/apt.conf (o en cualquier archivo en /etc/apt/apt.conf.d/*), es necesario añadir el siguiente bloque de configuración en /etc/apt/preferences para que las actualizaciones automáticas funcionen (para más información consulte apt_preferences(5)):

Package: *
Pin: release o=Debian,n=wheezy-updates
Pin-Priority: 990

Cuando un nuevo paquete esté disponible a través de wheezy-updates, se anunciará en la lista de correo debian-stable-announce.

Remarco esta parte:
Tenga en cuenta que si ha configurado APT::Default-Release en su archivo de configuración /etc/apt/apt.conf (o en cualquier archivo en /etc/apt/apt.conf.d/*),

Si tenemos el archivo release, esto seria si tenemos un sistema mixto.

http://wiki.debian.org/AptPreferences

_________________
Cuando mi maestro me reprendió, me dijo: Alejandro Magno a los 20 años conquistaba el mundo, Yo le conteste "si pero tenia de maestro a Aristóteles".
Twitter: @mcuentos

 Perfil  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Dom May 29, 2005 7:00 am
Mensajes: 407
Ubicación: Panamá

Nota Publicado: Lun May 13, 2013 5:29 pm 
Arriba  
Hmm, tienen razón, estoy equivocado, my bad...

_________________
debian wheezy / minimal install / icewm / vimperator
"Entre más lideo con gente, más quiero a mi perro" - Oscar Wilde
"No good deed will go unpunished" - Anonymous

 Perfil  

Desconectado
Forista Mayor
Forista Mayor
Avatar de Usuario

Registrado: Jue Ago 24, 2006 7:00 am
Mensajes: 598

Nota Publicado: Lun May 13, 2013 5:56 pm 
Arriba  
ok perfecto, ya decía yo que todo esto me sonaba un poco raro. Deberían editar el primer post para evitar más confusiones entre los demás usuarios.

Gracias.

 Perfil  

Desconectado
Forista Medio
Forista Medio
Avatar de Usuario

Registrado: Dom May 29, 2005 7:00 am
Mensajes: 407
Ubicación: Panamá

Nota Publicado: Mar May 14, 2013 12:39 am 
Arriba  
Ya está hecho :)

_________________
debian wheezy / minimal install / icewm / vimperator
"Entre más lideo con gente, más quiero a mi perro" - Oscar Wilde
"No good deed will go unpunished" - Anonymous

 Perfil  

Desconectado
Forista Menor
Forista Menor
Avatar de Usuario

Registrado: Mar Feb 01, 2011 8:14 pm
Mensajes: 69
Ubicación: Argentina

Nota Publicado: Vie Jun 14, 2013 1:38 am 
Arriba  
Holas!!! Estoy leyendo, todo muy interesante, voy a ver bien que hago, supongo que me mantendre en Testing, mientras comento: por lo que veo muchos usan debian-multimedia, a traves de la cuenta de facebook la gente de Debian mando lo siquiente:
Citar:
Remove unofficial !debian-multimedia.org repository from your sources


esto esta en:
[url]
http://bits.debian.org/2013/06/remove-d ... media.html
[/url]

No entiendo mucho. Así que puedo estar comentando algo que ya sea muy obvio para todos en ese caso disculpas.

Saludos.

 Perfil WWW  
Mostrar mensajes previos:  Ordenar por  
 [ 31 mensajes ]  Ir a página Anterior  1, 2, 3  Siguiente
Nuevo tema Responder al tema

Saltar a:  


 Temas relacionados   Autor   Respuestas   Vistas   Último mensaje 
gory-lap (Windows Managers) - (Debian [Testing/Stable])

en Concurso Screenshots 2009

gory

1

1661

Dom Ene 03, 2010 12:18 am

Ayax Ver último mensaje

[Tip] Instalar Clementine 1.1 RC1 en Debian testing (Wheezy)

en Documentación

Yoyo

0

1666

Dom Oct 14, 2012 1:01 am

Yoyo Ver último mensaje

[Tip] Iceweasel 16.0.1 en Debian testing Wheezy desde Waldorf

en Documentación

Yoyo

3

3331

Dom Oct 14, 2012 8:59 pm

niky45 Ver último mensaje

[Tip] Instalar Cinnamon 1.6.1 en Debian testing (Wheezy) usando el repositorio de LMDE

en Documentación

Yoyo

2

3590

Dom Oct 14, 2012 2:07 pm

Yoyo Ver último mensaje

[Howto] Cómo instalar el Artwork de SolusOS 2 en Debian testing (Wheezy) Gnome 3.4

en Documentación

Yoyo

3

3048

Mié Jun 27, 2012 9:32 pm

CharlieBros Ver último mensaje



¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: Todos los horarios son UTC + 1 hora [ DST ]
Traducción al español por Huan Manwë
phpBB SEO